Vue 不支持 IE8 及以下版本,因为 Vue 使用了 IE8 无法模拟的 ECMAScript 5 特性。但它支持所有兼容 ECMAScript 5 的浏览器。使用Vuex和axios时需要浏览器支持:Promise,而IE并不支持Promise。

对于低版本的浏览器,我们怎么做判断呢?

多步骤获取各个游览器的内核和版本
多步骤获取各个游览器的内核和版本

通过这个方法可以获取当前的浏览器内核和版本号

剩下来事情就是做比对,就没啥难度了。主要上面的 逻辑条件,因为现在的浏览器都是多核的,所以他们是有先后关系的。

特别注意,这个兼容函数 应该不能用新特性,因为在低版本游览器上面运行,es6的语法是不支持的。

Leave a Reply

Your email address will not be published. Required fields are marked *